Use of RSA keys in Gnupg

Stark, Roman
Fri, 20 Oct 2000 16:52:24 -0500

I posted this a few days ago once, does anybody have any ideas?  I still
have not been successful at using an RSA key to decrypt in gpg.

> I am trying to use RSA keys in gpg but without success.
> I created an RSA key pair in PGP, exported both keys and imported both to
> gpg. The result of the import is:
> gpg: Warning: using insecure memory!
> gpg: key F4497081: secret key imported
> gpg: key F4497081: public key imported
> gpg: key F4497081: secret and public key don't match
> gpg: Total number processed: 2
> gpg: imported: 1 (RSA: 1)
> gpg: secret keys read: 1
> gpg: secret keys imported: 1
> The message that secret and public key don't match was worrying. Anyway I
> encrypted a file using this RSA key which worked fine but when I tried to
> decrypted it I get the following:
> Ok ignore the insecure memory mgs. We heard enough about it...
> gpg: Warning: using insecure memory!
> gpg: protection algorithm 1 is not supported
> gpg: encrypted with 1024-bit RSA key, ID F4497081, created 2000-10-18
> "roman stark <>"
> gpg: public key decryption failed: unknown cipher algorithm
> gpg: decryption failed: secret key not available
> However, using PGP to decrypt the file, which was encrypted with GPG work
> just fine. Does anybody have any ideas as to why the decryption does not
> work?
> Thanks
> Roman
> Roman Stark
> 400 E. 7th Street
> Poplars 158
> Bloomington, IN 47405
> phone: (812) 855-0428
> email:
-- Archive is at - Unsubscribe by sending mail with a subject of "unsubscribe" to