encrypting as "nobody"

Erik Wessel erikw@street-cance.com
Mon, 18 Sep 2000 10:25:56 -0500

I have a perl CGI script which I need to have encrypt data for me. 
Since it's a CGI it runs as "nobody". But on my system "nobody" 
doesn't have a home directory.  So I tried using the --homdir flag 
(--homedir erik) to point to a different users home directory, but 
when I do, I get this error in my http error log:

gpg: keyblock resource `erik': file open error
gpg: keyblock resource `erik': file open error
gpg: erik: skipped: public key not found
gpg: [stdin]: encryption failed: public key not found

I know this decreases security, but on the off chance it would work, 
I made my pubring.gpg readable by all, but I still get the same error.

I can get the script to work fine when I run it under my user ID from 
the command line.

Does anyone know what I'm missing?

Erik Wessel
233  North  Water  Street
Milwaukee  WI  53202
ph   414 | 765 | 0333
fax  414 | 765 | 1207

Archive is at http://lists.gnupg.org - Unsubscribe by sending mail
with a subject of  "unsubscribe"  to gnupg-users-request@gnupg.org