gpg 1.0.3 won't compile on HPUX 10.20

David Chin
Sat, 23 Sep 2000 14:03:52 -0400

Hash: SHA1

Content-Type: text/plain; charset=us-ascii

In message <>, David Ellement writes:

> On 000922, at 16:24:36, wrote:
> > I was able to, but using /opt/softbench/bin/cc with CFLAGS set to
> > "-Ae +DA1.1 +DS2.0 -D_LARGEFILE64_SOURCE". Maybe you can turn off strict
> > ANSI mode for gcc (which seems odd since the default is not to use strict
> > ANSI).
> I too was unable to compile 1.0.3 on HPUX 10.20 with gcc. I tried
> your suggestion, and while the compile progressed further than with
> gcc, the resultant binary failed almost all the checks when I ran
> 'make check'.
Sorry for the incomplete info. I also had to munge up cipher/Makefile (or cipher/ if you like). For some reason, I've never had luck creating a dynamic object file in one pass using softbench/cc or gcc. So, I added these lines to cipher/Makefile: tiger: $(srcdir)/tiger.o $(LD) -b -o $@ $(srcdir)/tiger.o tiger.o: $(srcdir)/tiger.c $(COMPILE) $(DYNLINK_MOD_CFLAGS) -c $(srcdir)/tiger.c rndunix: $(srcdir)/rndunix.o $(LD) -b -o $@ $(srcdir)/rndunix.o rndunix.o: $(srcdir)/rndunix.c $(COMPILE) $(DYNLINK_MOD_CFLAGS) -c $(srcdir)/rndunix.c rndegd: $(srcdir)/rndegd.o $(LD) -b -o $@ $(srcdir)/rndegd.o rndegd.o: $(srcdir)/rndegd.c $(COMPILE) $(DYNLINK_MOD_CFLAGS) -c $(srcdir)/rndegd.c rsa: $(srcdir)/rsa.o $(LD) -b -o $@ $(srcdir)/rsa.o rsa.o: $(srcdir)/rsa.c $(COMPILE) $(DYNLINK_MOD_CFLAGS) -c $(srcdir)/rsa.c idea: $(srcdir)/idea.o $(LD) -b -o $@ $(srcdir)/idea.o idea.o: $(srcdir)/idea.c $(COMPILE) $(DYNLINK_MOD_CFLAGS) -c $(srcdir)/idea.c and commented out the original rules to make the dynamic objects. I also had to define LD. So, we compile to .o format, and then use ld to create the dynamic object file. My configure line: ./configure --prefix=/usr/local --disable-nls --enable-static-rnd=none \ --disable-dev-random --host=hppa1.1-hp-hpux10.20 --enable-m-guard and I edited config.status to have: s%@CFLAGS@%+O4 +Onolimit -w -z +ESlit -Ae -D_HPUX_SOURCE \ -D_LARGEFILE64_SOURCE%g s%@DYNAMIC_CIPHER_MODS@% rndunix rndegd tiger idea%g s%@CC@%/opt/softbench/bin/cc -Ae +DA1.1 +DS2.0%g (i.e. adding the stuff for large files to CFLAGS, and removing rndlinux from the dynamic cipher mods). The "+DA1.1 +DS2.0" is just to ensure that PA1.1 machines can run the resulting binaries. If I had time, I muck up the autoconf and automake stuff to make these things correct for HP-UX, but, my dissertation calls... :( I haven't tried compiling with gcc (2.95.2) at all. I've had some problems with gcc, and I don't know what causes them. Now, after all this is done, when you run "make check", you'll probably get a whole bunch of warnings about random numbers not being random enough. Just run the Entropy Gathering Daemon: ./checks/entropy. And then run the checks. Hope this is helpful. Cheers, - --David Chin "What, me weird?" -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.0.3 (HP-UX) Comment: Exmh version 2.2 06/23/2000 iD8DBQE5zPCIeMehOsd6Gs0RAinLAJ4wFTnwjvkLCmDhaYgrzpeZITcDDgCfYcZq zwavB1w40SOqbgKe0p4LE/s= =lxBs -----END PGP SIGNATURE----- -- Archive is at - Unsubscribe by sending mail with a subject of "unsubscribe" to