Help! cant do a thing - trustdb.gpg not being created

Darren Scott
Tue, 26 Sep 2000 10:07:41 +0100

This is a multi-part message in MIME format.
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit


I'm having some real problems getting GnuPG working: A trustdb.gpg just
never gets created - and every time I try to do something with my newly
generated key pair, I get the following:-

gpg: fatal: ./.gnupg/trustdb.gpg: can't open: No such file or directory

I've deleted my ~/.gnupg directory several times and started from
scratch, following the handbook and howto instructions on generating a
new pair. I can do --list-keys and everything looks fine. Then I try
--edit-key and the same message appears yet again! --update-trustdb
gives the same error as well

I've seen some postings from people who have deleted their trustdb.gpg
files, and had new ones automatically created but not for me! I've even
given world-write access to ~/.gnupg in case it was a permissions
problem - but no.

I renamed my ./gnupg directory, and tried to import the keyring into a
new one (as I had seen somebody else doing in the list archive).
Everything except trustdb.gpg was created...

gpg: ./.gnupg/options: new options file created
gpg: ./.gnupg/secring.gpg: keyring created
gpg: ./.gnupg/pubring.gpg: keyring created
gpg: pub  1024D/C31A67A6 2000-09-25   Darren Scott (Executive Director)
gpg: key C31A67A6: public key imported
gpg: fatal: ./.gnupg/trustdb.gpg: can't open: No such file or directory

Thanks for any help or advice - please cc: replies to me personally as
I'm not a subscriber.

Version 0.9.8/Red Hat 6.1 - same problem with both RPM and source

Darren Scott
Production Director
Content-Type: text/x-vcard; charset=us-ascii;
Content-Transfer-Encoding: 7bit
Content-Description: Card for Darren Scott
Content-Disposition: attachment;

tel;cell:+44 (0)7974 131603
tel;fax:+44 (0)1225 312878
tel;work:+44 (0)1225 780040
title:Production Director
adr;quoted-printable:;;King's Court=0D=0AParsonage Lane;Bath;Banes;BA11ER;England
fn:Darren Scott


Archive is at - Unsubscribe by sending mail
with a subject of  "unsubscribe"  to