keyfile problem(s)

Wed Apr 11 01:33:03 2001

  Timo built a Win32 version of GnuPG 1.05g for use with WinPT and I
noticed something strange in its behavior.
 With this new version of GPG apparently the keyring file formats are
a little different so Timo recommended exporting both keyrings,
deleting your keyrings, and then importing them from the files we
exported.  Then delete the trustdb, and rebuild that.
 My keyrings are kept in an encrypted partition using Scramdisk.  I
have that drive mounted as drive-letter S: and the full path to the
keyrings is S:\pgp_keyrings\pubring.gpg 
  (although I think the the options file you use regular forward
slashes to tell GPG where the files are located.

 You get the picture.

  In any case when I tried to import my public keyring (bearing in
mind that the real keyrings are deleted at this point) it imported
them into the C:\gnupg directory instead of my encrypted S: drive. 
Then when I imported the secret keyring it gave me this error:

gpg: keyblock resource `S:/PGP_Keyrings/secring.gpg': file open error
gpg: keyblock resource `S:/PGP_Keyrings/pubring.gpg': file open error
 which is the error I always get if I forget to mount my scramdisk
partition and use GPG.  Except this time the scramdisk partition was
mounted.  And just like with the public keyring, GPG did import the
keyfile, but it created it in the C:\gnupg directory.

  Everything worked fine after I moved the new keyring files in the
scramdisk partition, but I just thought it was odd that it didn't
created the new files in the area where the options file told them
to.  I suspect it was because the actual destination files were

  The Central New York Linux User Group
 Now with one of them web page thingies! <->