"out of secure memory while allocating 4316 bytes"

Jim Breton jamesb-gpg@alongtheway.com
Wed Jul 4 11:10:01 2001

Hi, I am using gnupg-1.0.6 on a Debian potato system, kernel 2.4.6 (had
this problem on 2.4.5 as well).  This computer has 256 MB of RAM.

When I try to decrypt a file, I can get this error:

gpg: out of secure memory while allocating 4316 bytes
gpg: (this may be caused by too many secret keys used simultaneously or
due to excessive large key sizes)

I am using a 4096-bit key; however, I did a google search on this error
and found one other person with a similar problem:


After reading that, I tried my own and indeed, this does seem to only
occur if I fail to type my passphrase correctly the first time.

I have been compiling gnupg with the --enable-m-guard option but I just
tried a re-compile without that option and the same thing happens.

Anyone got ideas on what is going on?

I am not currently subscribed, please copy me on any responses.

Thank you.

P.S. I have not been able to find a good, detailed description of what
"m-guard" _actually_ does, is this information available somewhere?