compiling on solaris2.6, sparc, using cc

Chris Drumgoole
Fri Jun 8 17:40:02 2001


I am trying to compile version 1.06 on a Solaris 2.6 machine (sparc) using the sun compiler cc.

setenv CC "cc"

so, I wun configure, it finds the cc compiler, it seems ok.  Then I try

make  all-recursive
make[1]: Entering directory `/usr/share/src/gnupg-1.0.6'
Making all in intl
make[2]: Entering directory `/usr/share/src/gnupg-1.0.6/intl'
cc -c -DLOCALEDIR=\"/usr/local/share/locale\"
-DLIBDIR=\"/usr/local/lib\" -DHAVE_CONFIG_H -I.. -I. -I../intl  intl-compat.c
"/usr/include/stddef.h", line 21: invalid type combination
"/usr/include/stddef.h", line 21: warning: useless declaration
"/usr/include/stddef.h", line 21: warning: typedef declares no type name
cc: acomp failed for intl-compat.c
make[2]: *** [intl-compat.o] Error 2
make[2]: Leaving directory `/usr/share/src/gnupg-1.0.6/intl'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/share/src/gnupg-1.0.6'
make: *** [all-recursive-am] Error 2

I tried setting CFLAGS to various things, including -DSYSV, but no luck.

oh.. when I ran configure, some of the messages that caught my eye:

checking size of unsigned short... (cached) 0
checking size of unsigned int... (cached) 0
checking size of unsigned long... (cached) 0
checking size of unsigned long long... (cached) 0
configure: warning: Hmmm, something is wrong with the sizes - using

have any ideas?

Thank you!

chris drumgoole
caen systems group
university of michgian