GnuPG command line w32

Johan Wevers
Thu May 3 23:54:01 2001

You, Werner Koch, wrote:

>> My first test made it crash: "gpg -kvv" resulted in an application error.
>> However, "gpg -kv" worked fine.

> Please give me some more details. I can't reproduce this.
This was on my machine at work, I'll do some more tests tomorrow. OS: Win2000 SP1 gpg.exe placed in C:\U, a directory in the path. Registry entry to homedir c:/home/johanw/.gnupg/, where the options file, the public keyring and the trustdb are located. The secret keyring is located on a CD-ROM drive (trustdb should be writable or the program crashes). This is indicted in the options file: it contains a line secret-keyring d:/home/johanw/.gnupg/secring.gpg (gpg creates an empty secring on c: anyway). I load the idea and skipjack modules (I've ported skipjack the same way as idea on the winpt site to win32).
> BTW, the same error should occur under GNU too.
On my Linux box (libc5, kernel 2.0.38) gpg -kvv works fine with 1.0.5. -- ir. J.C.A. Wevers // Physics and science fiction site: // PGP/GPG public keys at