Lost Cipher and Hash preferences

David Shaw dshaw@jabberwocky.com
Sun Apr 21 19:19:01 2002

On Thu, Apr 18, 2002 at 10:48:38AM -0700, Steve Butler wrote:
> Get back to you on that.  I have a query out to them.  So far, this is all I
> have (other than looking at their and our public keys):
> "I was looking at your key and apparently you use GnuPGP. You will be the
> first group that I send data to that is using GPG. In a nutshell, I tried to
> encrypt your file, and it starts to, pulls up the banner info for your key,
> and then asks if I want to use this key. But when I say yes, it pauses, and
> then returns to the directory where the file resides. (when I use normal PGP
> it displays the filename with a .pgp extension - indicating a successful
> encryption.)  When I look at the directory nothing is encrypted. 

> The client is using version 7.0.1

Hmm.  I tried encrypting to your key here with 7.0.3 and all was well.

I don't know what was exactly was changed between 7.0.1 and 7.0.3 (or
if what was changed is relevant to this problem).  That said, here are
two things to try:

1) Add preferences to your key and give it to the customer to try
   again.  You can add preferences by going to the --edit menu, using
   "delsig" to delete your self-signature, then using "sign" to
   re-sign it with itself.  (gpg -u 1B32D54B --edit 1B32D54B)

   Make a backup first to be safe. :)

2) Ask your customer to upgrade (hard, I know).


   David Shaw  |  dshaw@jabberwocky.com  |  WWW http://www.jabberwocky.com/
   "There are two major products that come out of Berkeley: LSD and UNIX.
      We don't believe this to be a coincidence." - Jeremy S. Anderson