invalid armor header
Tue Aug 13 18:31:01 2002

I installed GnuPG on my debian woody system a few months ago, made my key,
exported it and imported a couple.  It works fine with Mutt and I was happy. I
don't know what version I had at the time.  I now have 1.0.6-3.

This morning I got an encrypted message and went to get the key for this
person.  I first tried:

gpg --recv-key --keyserver <>

That didn't work; so I went to and got the text file for this
person and ran:

gpg --import <text-file>

I got and error - invalid armor header.  I can't figure out what to do to get
this thing imported.

I read the manual again (instead of the little notes I had) and it said that
'recv-key' required the KEY ID instead of the email address.  I tried the
command with the KEY ID (the digits given at the site which I assume is
correct) and got that it was an invalid ID. The syntax I used was:

gpg --recv-key --keyserver  12345678

I did a quick look through the archives for subjects with armor in them and
didn't see anything for the last 7 months that has to do with this issue.

This morning I got another key on someone I already had and tried to import it
and got the armor error.  I tried it at work on the ISP server and used what I
think was the same key.  It worked. They have 1.0.6 on there.

Any advice on this?