Tue Jul 9 17:16:01 2002

Hash: SHA1

Hi all,=20

I've huge difficulties (on Linux) to deal with binhex PGP data sent by
some boring customers :

% file report.pgp
report.pgp: BinHex binary text, version 4.0

...and of course :

% gpg report.pgp
gpg: no valid OpenPGP data found
gpg: processing message failed: eof

I've tried to use the "macutils" package wich converts binhex :

% hexbin -U report.pgp
% file report.pgp.text=20
report.pgp.text: data

% gpg report.pgp.text

And here everything seems fines, gnupg recognizes that the file is
ciffered and which public key has been used. It also provides me the
right secrete key ID, asks me for the passphrase, says it's good, but
then fails to deciffer the file and tell me that secret key isn't

Of course I've verified that this secrete key is really available, and
that IDs provided by GnuPG before asking for the passphrase do really match
this key.=20
So I really don't understand : probably there is something missing in
the conversion but how could I could I complete it ? (if possible)
Did anyone encountered the same kind of problem ?

I don't think it's a gnupg specific problem, because I also tried with
pgp5 and get the same results : the right public and related secrete key
are identified (among 2 other one I have), passphrase is accepted, but
both PGP and gnuPG deny existence of the secrete key.

=2D --=20
Fingerprint B10D AE2C 30F9 B054 9B4B  DD16 E76D FC7A 7219 B54E
GnuPG  Get Private! 0x7219B54E
Version: GnuPG v1.0.7 (GNU/Linux)