problem compiling 1.0.7 for win32

Brad Tarver
Tue Jul 9 20:53:01 2002


I'm an experienced linux user. I've been using it for 5 years. I've
never compiled code on linux for windows 32 before tho.

I'm trying to compile gnupg 1.0.7 using the instructions from the
README.W32 file from the win32 dist of gnupg 1.0.6.

I'm using mingw32-cpd-0.3.0, gcc-2.95.2, and binutils-2.9.1 on Red Hat 7.2.

Mingw32 installed fine.

I put 'export
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/btarver/lib/mingw32-cpd/lib' in
my .bash_profile after installing mingw32. Yhen ran 'source .bash_profile'

I ran 'scripts/ --build-w32' from the gnupg-1.0.7 with no errors.

I get no errors with these:
make  all-recursive
Making all in intl
Making all in zlib
Making all in util
Making all in mpi
Making all in cipher
make  all-am

I run into errors when trying to compile in the tools sub dir:
/home/btarver/lib/mingw32-cpd/i386--mingw32/bin/ld: cannot open
-lws2_32: No such file or directory

Making all in tools
make[2]: Entering directory `/home/btarver/gnupg-1.0.7/tools'
/home/btarver/lib/mingw32-cpd/i386--mingw32/bin/gcc  -g -O2 -Wall   -o
gpgsplit.exe  gpgsplit.o ../zlib/libzlib.a ../cipher/libcipher.a
../mpi/libmpi.a ../util/libutil.a  -lws2_32
/home/btarver/lib/mingw32-cpd/i386--mingw32/bin/ld: cannot open
-lws2_32: No such file or directory
make[2]: *** [gpgsplit.exe] Error 1
make[2]: Leaving directory `/home/btarver/gnupg-1.0.7/tools'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/btarver/gnupg-1.0.7'
make: *** [all] Error 2

What do i need to do to get this working?


Brad Tarver
IT Director
Rankin County Board of Supervisors
601 825 9633
601 824 2557 Fax