gpg 1.0.7 MingW32

David R. Bergstein
Sat Jul 13 22:08:01 2002


I am glad to hear that the patches I posted helped you.  Credit for the HKP
keyserver patch actually belongs to Keith Ray (; his original
PGP signatures were retained within that patch file.  The ws2_32 libraries
never worked for me either, that is why I linked the executable to wsock32

Maybe you can enlighten me as to the purpose of the files in the "po"
subdirectory.  One of our fellow users, Brad Tarver, on cc: encountered the
same issue you did with the missing makefile.


- David

David R. Bergstein
Systems Engineer and Blues Musician -
Heart of Blue - bookings on-line at
OpenPGP Public Key 0xE1F138CA - For info see
Key fingerprint = C86E CA2A 4171 AC73 91D7  3DCE 8832 D764 E1F1 38CA

> -----Original Message-----
> From: Ben L. Perkins []
> Sent: Saturday, July 13, 2002 12:34 PM
> To:
> Cc:
> Subject: gpg 1.0.7 MingW32
> David,
> Thanks for posting your patches to get gpg 1.0.7 building
> successfully with mingw32.  After the relative ease with which gpg
> 1.0.6 cross-compiled, I'd hit a roadblock with getting 1.0.7 working.
> I struggled with trying to get ws2_32 to work properly for a while
> and also tried getting the mingw32 compile to work under Cygwin on
> Windows 2000.  Both of them were yielding lots of frustration and very
> little progress.
> The only problem I had cross-compiling from my Linux system after
> applying your patches was that for some reason configure was generating a
> "" in the "po" subdirectory but no Makefile.  After copying
> into Makefile, I was able to get a working build.
> Thanks again.
> --
> Ben L. Perkins -=- Houston, TX, USA