GnuPG 1.0.7 not compiling on Solrais 2.7

Leigh S. Jones, KR6X
Sat May 4 01:37:02 2002

I succeeded in compiling on a slightly earlier version of Sun
Solaris using gcc and gnu make on a Sun Ultra 1.

Our situations have some similarities.  I did not want the
make program to install the executable.  Instead, without
running ">make install", I produced the gpg executable in
the g10 directory.  No --prefix option was required in
make.  I actually had no reason to include any parameters
on the "./configure" line as the program configured and
compiled effortlessly.  But I didn't perform a "make install".
I just put the executable in the path.  This was possible due
to the intended use of the particular system on which I'm

1) no keys will be generated
2) no encryption will be performed
(these two factors combined mean I had no concern for
any issues regarding entropy)
3) only clearsigning of documents and verification to
known keys will be required
4) all keyring updates will be performed by transferring
copies of the keyring and trust data base files from
another system
(these factors combined mean no need for keyserver

The gnupg 1.0.6 installation that I replaced had been
communicating with the keyservers OK, while I notice
that the capability was not maintained by my upgrade.
I believe that some portions of the gpg program may
have been spun off into separate executables with the
release of gnupg 1.0.7 -- and I did not install the
separate executables properly.  This would be my
fault, but I have no need to fix it.

You might have some success with this approach
probably more than I did...

The line 226 error jumps out at you if you look at
the code.  And int * named sequence is passed as a
parameter, and an attempt is made to initialize the
value of an integer from the value pointed to by
sequence.  Perhaps gcc accepts this (creation of a
local variable and simultaneous initialization from
a variable) where other compilers would only
allow the initialization from a value that is known at
compile time.  If you change line 226 to two lines
that read:

int i;
i = *sequence;

then you'll be able to move on and see if other
similar problems exist with your compiler.

----- Original Message -----
From: <>
To: <>
Sent: Friday, May 03, 2002 15:23
Subject: GnuPG 1.0.7 not compiling on Solrais 2.7

> I'm trying to compile Gnu 1.0.7 on Sun Solaris 2.7 without success. I do
> not have write access to the /usr/local/bin directory so instead I ran the
> configure command as follows:
> ./configure -enable-static-rnd=none -prefix=$NEW_DIRECTORY
> where NEW_DIRECTORY is where i need the pgp binaries to be generated.
> then I ran make
> Then Make install
> But I get the following errors at the end of both make & makeinstall
> commands :
> cc: Warning: -s conflicts with -g. -s turned off
> "./rndlinux.c", line 226: warning: assignment type mismatch:
>         pointer to void "=" pointer to function(void) returning int
> ld: fatal: option -h and building a dynamic executable are incompatible
> ld: fatal: Flags processing errors
> make[1]: *** [rndlinux] Error 1
> make[1]: Leaving directory `/users/webtools/pgp/gnupg-1.0.7/cipher'
> make: *** [install-recursive] Error 1
> What am I missing  , If I install gcc, do you think this problem will be
> resolved ?
> Thanks,
> _______________________________________________
> Gnupg-users mailing list