viewing encrypted message in pine
Sat May 4 01:48:02 2002

I have my .pinerc setup basically the same
way, except that where I read how to do it,
they use BEGINNING instead of LEADING.
Regardless, I've tried it both ways since
reading other examples & it still didn't work.
And no, I couldn't decrypt from the command
line. It says that the secret key couldn't be
found. This happens both when trying to read
a message I've written & has been encrypted
to me, & with messages from the one other
user whose public key I've imported. Also set
the trust on it to full. This problem is going
on on my FreeBSD 4.5 system. There were
no problems when I built the port, & it will
sign or sign/encrypt fine. I stayed up almost
all one night reading everything I could find
on the matter before coming to this mailing
list, so I just want everyone to know I'm not
looking for a "fix it for me". :-) Learned that
early on in the unix community. Thanks for
your answer & if you can figure out maybe
what I'm doing wrong. I really don't think
it's the system, probably just something I
have set wrong or am doing wrong.

-----Original Message-----
From:	"" <> on =
behalf of	"Owen Blacker" <>
Sent:	Fri, 3 May 2002 22:14:28 +0100 (BST)
To:	"Thien Huu" <>
Cc:	"GPG Users list" <>
Subject:	Re: viewing encrypted message in pine

Hash: SHA1

Thien Huu wrote (2002-05-02 T 18:16 -0500):
> I've got pine & gnupg working to the point where I can sign, encrypt
> or both, sending messages, but when I get a message back from someone
> on my keyring, or if I try to view an encrypted message I sent which
> did the encrypt to self routine, I can't figure out how to view it.
> I've read the man pages & checked the send & receive settings & mine
> are exactly the same. I've searched gnupg docs, did searches on
> google, but so far no luck. Read the examples & docs that install with
> the programs too, but so far, no luck. Hope someone understands what
> I'm trying to ask. I also tried changing ISO-8859-1 to ascii settings,
> thinking maybe the program didn't like the character set of the fonts
> I was using. Thanks for any & all help I can get on this. Not trying
> to get a free ride, just a push in the right direction, like maybe
> some good links that have a variety of good examples.

Have you set up a display-filter ?

One of the lines in my .pinerc reads:

   display-filters=3D_LEADING("-----BEGIN PGP ")_ /usr/local/bin/gpg =

, and it processes everything quite nicely.

Can you decrypt on the command line ok in that OS?  It's not a problem
with having ported your secret key from Windows to a unix, is it?  (I
think that one's in the FAQs, but you need to set your passphrase to be
an empty string whilst you port it)


O x
- --=20
Owen Blacker | Senior Software Developer and InfoSecurity Consultant
See -- more about my PGP keys
Sig  0xb48e805e | 0e31 ac2a 4ff2 62a0 89da  ddef 4223 99a6 b48e 805e
- --
They that can give up essential liberty to obtain a little temporary
 safety deserve neither liberty nor safety --Benjamin Franklin, 1759
Version: GnuPG v1.0.6 (FreeBSD)
Comment: For info see


Gnupg-users mailing list