/dev/null ownership and moving keys

David T-G davidtg-gnupg@justpickone.org
Mon May 13 14:59:02 2002

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Hi, all --

I have multiple keyrings defined in my options file to give me some
semblance :-) of order.  The last keyring defined is a "catch-all" ring
that catches keys as they are received.  I have a script that moves keys
from the catch-all ring to some other specified ring (mostly through
brute force; if there are elegant methods of key management I'd love to
know about them).

Since moving to gpg 1.0.7, I find that

- gpg reports "unsafe ownership of /dev/null"; root.root at 666 has
  worked for us but I wonder what it *should* be

- everything ends up in my primary keyring!

- gpg --list-keys | grep ^/ only gets part of the way through my list

I'm stuck again and need help getting the details worked out.  I
certainly need to have keys drop into my catch-all ring (actually, if
there's an easy way to specify a target ring so that I can configure my
mail program to call gpg that way based on the folder I'm reading, that
would be excellent, too) and to figure out how to list all of my rings.


David T-G                      * It's easier to fight for one's principles
(play) davidtg@justpickone.org * than to live up to them. -- fortune cookie
(work) davidtgwork@justpickone.org
http://www.justpickone.org/davidtg/    Shpx gur Pbzzhavpngvbaf Qrprapl Npg!

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.0.7 (GNU/Linux)