Interoperability problems between Sparc and x86?

Jay Sauls
Fri May 17 13:14:38 2002

I'm stumped by this problem and need a little help:

A customer has encrypted a large number of individual files (> 1000) using 
asymmetric encryption with GPG 1.06 on Solaris.  They also signed the files 
(using a key that I don't have, but since I don't care to verify the 
signature, I'm ignoring that for the moment).

All of the files fail decryption on Red Hat Linux on x86 using GPG 1.06 or 
GPG 1.07. The error is:

gpg: [don't know]: invalid packet (ctb=2d)

I hacked the code a bit to add a printf statement to parse() to see how many 
times it's being called before it fails, and it's only called once.  So 
apparently the first byte in the file is 0x2d, and apparently this is bad 
since it fails the  !(ctb & 0x80) test in parse().

I tried the freeware PGP Command line version for windows (ver 6.5.8) 
running on Windows 2000, and it failed silently when trying to decrypt the 
same file.

Now the weird thing is that I tried the commercial PGP package for Windows 
(version 7.0.3) and it sucessfully decrypts the file.

So what is going on here?  Is there an endianness problem between Sparc and 
x86 or something and PGP 7.0.3 knows how to deal with that?

For what it's worth, the files that are being encrypted are gzip'd text 
files (and yes, I know that GPG gzip's files inherently and that it's a 
waste of cycles to gzip a file that's already been gzip'd).

Thanks for any clues.

Send and receive Hotmail on your mobile device: