^M characters are embedded at the end of every record.

Steve Butler sbutler@fchn.com
Thu Nov 7 00:11:02 2002

Ah, but I do use a lot of Microsoft.  I also use a lot of Linux.  And I am
aware of how MPE (HP-3000 boxes) handles it's record termination.  Been
exposed to IBM mainframes.  Worked on Honeywell and Univac boxes.  

And I have a DSP chip and a PIC micro-controller at home that I would like
the time to play and program.  And just for grins, for my senior project in
college ('75) I wrote a tape based operating system for a PDP-11/20.  Had to
load the first iteration from the front panel switch register in binary.

No.  I'm not in love with Windows.  Neither do I like the X environment.
Neither Bill nor Larry are worthy of their following.  But, my employer
likes what I do with Oracle databases on Linux boxes so I am able to earn a
living.  On top of that, the EDI manager prefers that I play the technical
side of working with GnuPG.  So that software runs on Linux but I do keep a
version of GnuPG with WinPT on my Windows 2K workstation.

Now, do I really understand the workings behind GnuPG?  No.  I do have 60
quarter hours of college level math and could dig it out.  But there are
other things in life that are more fun for me right now. 

I've done my share of subtle windows bashing and really wish Oracle would
back away from X-Windows but I do try to be technically accurate to the best
of my knowledge when helping others out.  I am sure that there have been
times in this group where folks have felt that I must have hoof and mouth
disease.  Perhaps I just switched feet.

Please ignore the disclaimer below.  I can't prevent it from showing up.

-----Original Message-----
From: Nicolas Couture [mailto:nc@stormvault.net]
Sent: Wednesday, November 06, 2002 2:50 PM
To: Steve Butler
Subject: RE: ^M characters are embedded at the end of every record.

I was really sure this was made to piss of people that doesn't use m$ 

On Wed, 2002-11-06 at 17:37, Steve Butler wrote:
> Sorry Nicolas, ^M does not stand for Microsoft.  
> Any machine (PET, Apple, etc) that uses the ASCII <CR><LF> sequence as a
> end-of-line terminator will exhibit the same behavior if FTP'ed binary
> to a Unix type box.
> -----Original Message-----
> From: Nicolas Couture [mailto:nc@stormvault.net]
> Sent: Wednesday, November 06, 2002 2:11 PM
> To: GnuPG-users@GnuPG.OrG
> Subject: Re: ^M characters are embedded at the end of every record.
> On Wed, 2002-11-06 at 16:23, Loo, Peter wrote:
> > 
> > Hi All,
> > 
> > I created a text file in Windows environment.  Then it is encrypted and
> FTPed to a Unix server where the file is decrypted.  After decryption, I
> seeing ^M characters at the end of each record.  I have tried sending the
> file in both ASCII and BINARY modes.  Both modes don't help.  However, if
> send the plain text file via FTP in ASCII mode, the file does not contain
> and control characters.  Is there a way to decrypt the file into an output
> file without ^M character or is there a way to encrypt the file without
> This is not a GnuPG issue. All files created on notepad or some
> microsoft editor are full of ^M. Microsoft it says. The best you could
> do it not use windows but if you're addicted to this thing you could
> always use an other editor.

CONFIDENTIALITY NOTICE:  This e-mail message, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information.  Any unauthorized review, use, disclosure or distribution is prohibited.  If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.