invalid trustdb error

Andrew Stout
Tue Apr 8 11:44:32 2003


My ISP's server went down recently, and now that it's 'back up', GnuPG
will not execute for me.  They are running version 1.07 now, and I do
not know if this is a different version from before the 'crash'.

Here's the error I get when trying to execute GPG:

gpg: fatal: /home/username/.gnupg/trustdb.gpg: invalid trustdb

Everything work fine before they went down.  Now I get this error, and I
have not changed ANYTHING from when it always worked fine.  HOW DO I FIX

More info:

I've tried editing my key (--edit-key) and I get the same error.  I've
tried using --always-trust and still get the same error.  I've also
tried creating a brand new key (--gen-key) and it fails with the same
error after the random-data generation step.

I've looked in my .gnupg directory and see the file named trustdb.gpg
with a date on it AFTER the crash.  It is an empty file, however (zero
bytes).  I also see a file named trustdb.gpg.lock with a date well
before the date (a couple years ago, when I first started using GPG)
When I look at this file with a text editor I see just a few blank
spaces and some numbers (768 maybe?).  Don't know if this second file
has anything to do with it.

Can someone help me???


Andrew Stout