[Announce] 1.2.2 release candidate 2

Michael Nahrath gnupg-users@nahrath.de
Fri Apr 18 14:53:02 2003

This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

David Shaw wrote:

>>> ftp://ftp.gnupg.org/gcrypt/alpha/gnupg/gnupg-1.2.2rc2.tar.gz (2.8M)

>>Tried to compile it on MacOS 10.2.5.
>>It still needes special parameters:
>>After a "./configure --disable-asm" it compiles fine.
>>But simply doing "./configure; make; sudo make install" quits in make with:

>>_mpih-mul1.s:21:Unknown pseudo-op: .size
>>_mpih-mul1.s:21:Rest of line ignored. 1st junk character valued 109 (m).
>>make[2]: *** [mpih-mul1.o] Error 1
>>make[1]: *** [all-recursive] Error 1
>>make: *** [all] Error 2
>>--- >8 ---
>>I don't know what "asm" is but I do know that my system doesn't support it
>>and that it had to be manually disabled to compile GPG at least since 1.0.7

> That's very odd.  This was successfully tested on Darwin 6.2.  I
> wonder what changed.  

In doubt it may be Apple's fault ;)

May tht insatllation of the package management system 'fink' have changed

> Can you tell me the output of "uname -a" 

[michi@localhost]~$ uname -a
Darwin localhost 6.5 Darwin Kernel Version 6.5: Mon Apr  7 17:05:38 PDT
2003; root:xnu/xnu-344.32.obj~1/RELEASE_PPC  Power Macintosh powerpc

> as well
> as the contents of your mpi/asm-syntax.h file?

My running coppy was installed with "./configure --disable-asm" and thus the
file ./gnupg-1.2.2rc2/mpi/asm-syntax.h just contains:

/* created by config.links - do not edit */
/* Assembler modules disabled on request */

I just tried pure "./configure" and now is:

/* created by config.links - do not edit */
/* configured for OpenBSD/NetBSD/Darwin on powerpc */
#define ELF_SYNTAX
/* gmp2-2.0.2-ppc/mpn/powerpc-linux/syntax.h   Tue Oct	6 19:27:01 1998 */
/* From glibc's sysdeps/unix/sysv/linux/powerpc/sysdep.h */

/* Copyright (C) 1992, 1997, 1998 Free Software Foundation, Inc.
   Boston, MA 02111-1307, USA.	*/


/* This seems to always be the case on PPC.  */
#define ALIGNARG(log2) log2
/* For ELF we need the `.type' directive to make shared libs work right.  */
#define ASM_TYPE_DIRECTIVE(name,typearg) .type name,typearg;
#define ASM_SIZE_DIRECTIVE(name) .size name,.-name
#define ASM_GLOBAL_DIRECTIVE   .globl

#ifdef __STDC__
# define C_LABEL(name) C_SYMBOL_NAME(name)##:
# define C_LABEL(name) C_SYMBOL_NAME(name)/**/:

#ifdef __STDC__
# define L(body) .L##body
# define L(body) .L/**/body

/* No profiling of gmp's assembly for now... */
#define CALL_MCOUNT /* no profiling */

#define        ENTRY(name)				    \
  ASM_TYPE_DIRECTIVE (C_SYMBOL_NAME(name),@function)	    \
  .align ALIGNARG(2);					    \
  C_LABEL(name) 					    \

#define EALIGN_W_0  /* No words to insert.  */
#define EALIGN_W_1  nop
#define EALIGN_W_2  nop;nop
#define EALIGN_W_3  nop;nop;nop
#define EALIGN_W_4  EALIGN_W_3;nop
#define EALIGN_W_5  EALIGN_W_4;nop
#define EALIGN_W_6  EALIGN_W_5;nop
#define EALIGN_W_7  EALIGN_W_6;nop

/* EALIGN is like ENTRY, but does alignment to 'words'*4 bytes
   past a 2^align boundary.  */
#define EALIGN(name, alignt, words)			\
  ASM_TYPE_DIRECTIVE (C_SYMBOL_NAME(name),@function)	\
  .align ALIGNARG(alignt);				\
  EALIGN_W_##words;					\

#undef END
#define END(name)		     \


with that "make" fails like before.

Greeting, Michi

Content-Type: application/pgp-signature

Version: GnuPG v1.2.2rc2 (Darwin)
Comment: http://www.biglumber.com/x/web?qs=0x9A4C704C