can't run script

Atom 'Smasher' atom-gpg at
Sun Dec 21 12:19:02 CET 2003

Hash: SHA1

> #!/bin/tcsh
> gpg -d qce.asc > qce
> chmod 700 qce
> qce
> rm -f qce
> If I run this while in the dir containing the script all is fine
> but if I run it from elsewhere I get:
> gpg: can't open `qce.asc'
> gpg: decrypt_message failed: file open error
> I thought it was just a permissions thing so I 777'd everything just to
> see but still get the same thing.

either the top line of the script should be:
	cd /correct/directory/
or include the full path of all files you want to play with.

also, instead of `chmod` after the file is created, use `umask` before
it's created.


 PGP key -
 3EBE 2810 30AE 601D 54B2 4A90 9C28 0BBF 3D7D 41E3

	"The wireless telegraph is not difficult to understand.
	 The ordinary telegraph is like a very long cat.
	 You pull the tail in New York, and it meows in Los Angeles.
	 The wireless is the same, only without the cat."
		-- Albert Einstein

Version: GnuPG v1.2.3 (FreeBSD)


More information about the Gnupg-users mailing list