windows command line unresponsive

John Clizbe
Fri Jul 25 03:17:01 2003

Hash: SHA1

Lee Hinkleman wrote:

> After unzipping, making directory c:\gpg and
> copying into that directory gpg.exe, gpgv.exe, and gpgkeys_ldap.exe, and
> importing the registry key, gpg_w32.reg, into the windows registry,
> running c:\gpg\gpg.exe produced an MS-DOS window with:
> "gpg: keyring `C:/gpg\secring.gpg' created
> gpg: keyring `C:/gpg\pubring.gpg' created
> gpg: Go ahead and type your message ..."
> but commands like 'gpg --gen-key' are ignored when 'enter' is
> pressed...and Ctl+D, Ctl+Z, Ctl+other keys tried were ignored.
> When I tried re-starting in MS-DOS mode, the command line did respond
> with 'This program cannot be run in MS-DOS mode'.
> gpg works from the linux command line, but please tell me how I can run
> it in windows, too.

GPG wants you to type a message because it wants to encrypt something.
This is the default behavior if you don't tell it to do something else,
like import a key from a keyserver.

Escape from the input prompt by typing an End-of-File mark (control-D on
unix; contol-Z on DOS)

Run gpg under windows from a command prompt (COMMAND.COM or CMD.EXE). If
you execute it with no options, it will behave like a unix-style filter
wanting to encrypt.

- --
John P. Clizbe                   Inet:   JPClizbe AT comcast DOT nyet
Golden Bear Networks             PGP/GPG KeyID: 0x608D2A10
  "Most men take the straight and narrow. A few take the road less
traveled.  I chose to cut through the woods."
  "There is safety in Numbers... *VERY LARGE PRIME* Numbers
9:00PM Tonight on _REAL_IRONY_:  Vegetarian Man Eaten by Cannibals
Version: GnuPG v1.2.2-nr2 (Windows 2000)
Comment: Using GnuPG with Mozilla -