Problem: OpenPGP Module not listed

Ingo Klöcker
Thu May 15 00:04:02 2003

Content-Type: text/plain;
Content-Transfer-Encoding: quoted-printable
Content-Description: signed data
Content-Disposition: inline

On Wednesday 14 May 2003 03:58, Wolfgang Bornath wrote:
> ** Ingo Kl=F6cker (Mittwoch, 14. Mai 2003 00:14)
> > KMail has built-in support for clearsigned messages. But support
> > for PGP/MIME messages (where the signature is in a separate
> > attachment) is only available through a plugin (plugin has been
> > translated as "Modul" in the German translation). Read the howto at
> > if you want to know how to install the appropriate
> > plugin.
> Went there, done that, no t-shirt. Did not work.
> In detail:
> I downloaded all the files, did the 3-step waltz on them and the test
> $ echo "test" | gpg -ase -r 0xDEADBEEF | gpg
> worked all right (of course with my key-id).

What do you mean by "worked all right"? Did the pinentry program pop up?=20
Or did you simply enter the passphrase on the command line? If the=20
latter is the case then it did not work all right.

> All '.configure/make/make check/make install' returned no error so I
> assumed the installation went allright.
> Now I wanted to fill in the plugin into KMail but there is no plugin!
> According to the website there should be a directory
> /usr/local/lib/cryptplug with the file but there
> isn't. slocate (after updatedb) returns nothing with this name.
> I looked at the config.log in /misc/cryptplug-0.3.15 and found:
> ...
> configure:7762: checking for gpgme-config
> configure:7793: result: no
> configure:7959: creating ./config.status
> ...
> ...
> config.status:988: executing depfiles commands
> configure:9156:
>         CryptPlug v0.3.15 has been configured as follows:
>         CryptPlug GPGME: no
> ...
> This may be the problem. But how do I solve it? I'm not knowledgeable
> enough to solve this although I can do the normal installation of a
> .tar.gz package.

Well, obviously gpgme-config is missing for some reason (it should be in=20
/usr/local/bin if you didn't change the install prefix with the=20
=2D-prefix option). Did installing gpgme really work?


Content-Type: application/pgp-signature
Content-Description: signature

Version: GnuPG v1.2.1 (GNU/Linux)