Problem with Open BSD build

Patrick Chkoreff patrick at
Fri Nov 28 18:19:37 CET 2003

I'm having a very difficult time doing the 'make' for gnupg-1.2.3 on 
Open BSD platforms.

Today I downloaded gnupg-1.2.3.tar.gz onto a machine running Open BSD 
3.2 (GENERIC) #25.  I ran the ./configure script and then ran 'make', 
which complained:

Making all in tools
gcc  -g -O2 -Wall   -o mpicalc  mpicalc.o ../cipher/libcipher.a 
../mpi/libmpi.a ../util/libutil.a /usr/local/lib/libintl.a 
-L/usr/local/lib /usr/local/lib/libiconv.a
mpi-inline.h:119: Undefined symbol `_mpihelp_sub_n' referenced from 
text segment
mpi-add.c:136: Undefined symbol `_mpihelp_sub_n' referenced from text 
mpi-add.c:143: Undefined symbol `_mpihelp_sub_n' referenced from text 
... etc. etc. yadda yadda

I don't know why those symbols are undefined -- I ran 'nm' on libmpi.a 
and they appear to be in there.  The assembler files (*.S) are there, 
and did not seem to cause gcc any problems during the make process.  I 
do see that mpih-sub1.S is a symbolic link to i386-openbsd/miph-sub1.S, 
by the way, which says:

    .globl C_SYMBOL_NAME(mpihelp_sub_n)

Just as a test, I installed gnupg-1.2.3 onto a Linux machine and a Mac 
OSX machine and everything worked great.

Then I tried to install gnupg-1.2.3 onto a different Open BSD machine 
(3.0 generic #94), and I got the same problem described above with 
those undefined "mpihelp" symbols.

Does anyone have any idea why I am getting this same error on two 
different Open BSD machines?

-- Patrick

More information about the Gnupg-users mailing list