rpm --checksig problem

engage engage at n0sq.net
Sun Nov 30 16:14:04 CET 2003

On Sunday 30 November 2003 11:38 am, you wrote:
>hello engage,
>On Mon, 1 Dec 2003 05:10 am, engage wrote:
>> On Saturday 29 November 2003 09:00 pm, David R. Bergstein wrote:
>> >On Saturday 29 November 2003 09:35 pm, engage wrote:
>> >> Even though the public keys are on the keyring, running rpm
>> >> --checksig on packages tell me that the key is missing. I tried
>> >> downloading the packages from a different mirror but get the same
>> >> problem. I even tried rpm --import <pubkey> but that didn't help
>> >> either. This began after a fresh install of Mandrake 9.2 (was
>> >> running 9.0). GnuPG 1.2.3-3.1.92mdk.
>> >
>> >You may need to see if the path for the public keyring that RPM uses
>> > in MDK 9.2 is different than 9.0.   On my MDK 9.0 systems, the file
>> > that controls this behaviour is /etc/rpm/macros (see below for
>> > sample).
>> >
>> ># /etc/rpm/macros
>> >%_signature     gpg
>> >%_gpg_path      /etc/rpm-keys
>> I added the %signature line. The /etc/rpm-keys doesn't exist anywhere
>> on my system.
>> Adding the one line didn't help. As for /etc/rpm-keys, not sure of
>> what to do about that. I don't even know if that'll help even if it
>> is created.
>the value for the %_gpg_path should be the location of _your_ keyrings;
>by default this would be ~/.gnupg.  for more info on these incantations
>see <http://www.rpm.org/max-rpm/> or do a 'man rpm' and go to the
>you mentioned you're using Mandrake, but beware that the rpm package may
>be suffering the same symptom that the Red Hat one is.  see

I couldn't get to that url. I got an error message about port 443.

I modified the /etc/rpm/macros with the path to my keyring and it still don't 
work. I don't believe that was the problem because I downloaded rpm's from 
rpmfind.net that checked OK even prior to making any configuration changes. 
None of the rpm's from the 2 Mandrake mirrors that I used checked out OK.

More information about the Gnupg-users mailing list