[Sks-devel] Re: Key strangeness

Yaron Minsky yminsky at cs.cornell.edu
Sun Feb 8 13:20:37 CET 2004

Hmmm.  I am confused.  When I query 0x3A546EC2, I get the right key. 
Again, this is from sks.dnsalias.net.  Here's the URL I tried:


Any examples of keyserver weirdness would be more useful if they were
accompanied by the actual URLs that elicited the odd behavior.


David Shaw said:
> On Sun, Feb 08, 2004 at 09:58:23AM -0500, David Shaw wrote:
>> On Sun, Feb 08, 2004 at 07:22:09AM -0500, Yaron Minsky wrote:
>> > Uh, some more info please?  I still don't quite understand the nature
>> of
>> > the problem.  Both keyids pull up (different) keys belonging to one
>> > jeremy at durge.org.  And one of them looks very much like the other with
>> its
>> > primary key packet replaced.  But they are both there, at least on
>> > sks.dnsalias.net.  So I don't quite understand in what way SKS is
>> supposed
>> > to have malfunctioned.
>> Last night, I requested key 0x3A546EC2 from sks.keyserver.penguin.de.
>> The armored key blob that the server sent turned out to be key
>> 0x7EDB7A47.
>> In short, if I request 0x7EDB7A47, I get 0x7EDB7A47.  If I request
>> 0x3A546EC2, I still get 0x7EDB7A47.  The 0x7EDB7A47 I do get looks
>> like it has the self-sigs from 0x3A546EC2.
>> I just tried it again, with the same results from sks.dnsalias.net.
>> This is likely not a SKS-specific problem, as pgp.mit.edu (running
>> pksd) does the same thing.
> Recent update: some new valid self-sigs for and on 0x7EDB7A47 just
> showed up on sks.dnsalias.net.  Requesting 0x3A546EC2 still brings up
> 0x7EDB7A47 though.
> David

|--------/            Yaron M. Minsky              \--------|
|--------\ http://www.cs.cornell.edu/home/yminsky/ /--------|

Open PGP --- KeyID B1FFD916
Fingerprint: 5BF6 83E1 0CE3 1043 95D8 F8D5 9F12 B3A9 B1FF D916

More information about the Gnupg-users mailing list