error (and memory leak?)

5468696A6D656E thijmen at
Fri Jan 30 15:52:30 CET 2004

On this command:
"C:\Program Files\gpg\gpg.exe" --no-default-keyring --ignore-time-conflict 
--yes --always-trust --no-options --homedir "C:/WINDOWS/Application Data/GnuPG" --sign-key -u 87654321 

I always get this error (from util/ttyio.c, line 138)
gpg: fatal: open(CONOUT$) failed: rc=120secmem usage: 1408/1408 bytes in 2/2 blocks of pool 1408/32768

I found this old mail which seems to have the same error:
Anyone seen this first hand?

Additionally: The memory used to print this error on my screen seems not to get cleared:

Detected memory leaks!
Dumping objects ->
d:\programming languages\vc98\include\crtdbg.h(552) : {1139} normal block at 0x010C7B20, 129 bytes long.
 Data: <  pg: fatal: ope> 00 00 70 67 3A 20 66 61 74 61 6C 3A 20 6F 70 65 
Object dump complete.

Allthough gpg has in the above command pipes around it, this isn't a problem
for gpg usually. Host Os doesn't seem to matter, other command 
used in the same way (but with --batch in the
arguments) work nicely and predictable with pipes around gpg.

Experimenting with --no-tty gives:
gpg: Sorry, no terminal at all requested - can't get input

Additionally, when i use --command-fd 28 --status-fd 40 (those
are the actual file descripters of my pipes) i get the same error.

What am i doing wrong here?


__Thijmen Klok________

There are no bugs in NAH6 products. You are simply ironing out
any possible remaining cosmetic imperfections, that's all.
                    Zenon Panoussis, 2003-12-11

More information about the Gnupg-users mailing list