UTF8 passphrase problem (I think)

Tom Hardy rhardy at visi.com
Thu Jul 22 19:51:41 CEST 2004

On Thu, Jul 22, 2004 at 12:16:56PM -0400, Atom 'Smasher' wrote:
> hhmmm... still no answers on this?
> are there any characters in the passphrase that might be "special"?

It should all be in the ASCII range.  It doesn't appear that UTF-8 should 
be the problem, but it was the only thing I could think of, and I don't 
believe I clearly understand everything the gpg man page has to say about 
character sets.  When did gpg make the switch to UTF internal encoding?  
Would it be a problem if gpg inherited keyrings from before the switch?  

The two Windows keys were imported by directly reading *.pgp, *.pkr. and 
*.skr files.  The key from last year resided in a *.gpg file that the 
current gpg simply inherited during the latest system upgrade.
> have you tried accessing the key in another UTF8 environment? kgpg?
I currently have one home computer.  Two of the keys were created under 
kgpg; only the last one under the the UTF8 environment, and that's the one 
that works.  The two old ones were created under Windows in about 1998.  
They fail the same way as the kgpg one from last year, passphrase not 
accepted.  As I quickly ran into limits using kgpg and/or wasn't sure it 
wasn't interfering, I tried gpg --edit-key with adduid to produce the 
failures as well as the success.

> what are the chances that you forgot the correct passphrase?

I've checked it as carefully as I know how.  It is a quote from a book, 
the same for all keys.

> did you use the keys regularly?

I used the one from pgp 5.0 quite regularly in 1998; the one from 2.6 and
last year's gpg one were just experiments.

> is it possible that caps-lock was on either when the keys were created or 
> now that you're trying to use them?

Just tried that.  :-)

> not that i think this would help, but did you try entering ^J and/or ^M 
> before hitting <ENTER>? did you use ^V immediately before other control 
> (or special) characters?

Just tried that (^M and ^J), too.  It appears they are treated just like 
enter, terminating the sequence.  I don't know the significance of ^V; in 
any case I didn't use it, and I have only printable ASCII characters in 
the passphrase.

I'll try turning off UTF-8 systemwide once I figure out how.  There is 
supposed to be a script to do it which I just have to find and read about.

The old ones are on public servers as 0xD2E6A4B8, and 0xBC0E8015.  The 
new ones are privately held for now.

Tom Hardy  <*>  rhardy at visi.com  <*>  http://www.visi.com/~rhardy
  Just don't create a file called -rf. --Larry Wall

More information about the Gnupg-users mailing list