Failed to build gnupg-1.2.4 on Windows with Cygwin and gcc 3.3.1

John Clizbe JPClizbe at
Sun May 23 20:42:35 CEST 2004

Hash: SHA1

Alex Chen wrote:

> I downloaded gnupg-1.2.4 and tried to build it on Windows under Cygwin.
> I did that under the bash shell.  I first ran 'configure', which took
> quite some time to finish.
> Then I ran 'make' from the top directory.  The compilation seemed to
> went smoothly until
> it came to linking.  Then I got the following error messages:
> gcc  -g -O2 -Wall   -o mpicalc.exe  mpicalc.o ../cipher/libcipher.a
> ../mpi/libmp
> i.a ../util/libutil.a ../intl/libintl.a
> ../mpi/libmpi.a(mpi-add.o)(.text+0x258): In function `mpi_add':
> The list when on and on.  I suspect somehow the compiler was adding the
> leading '_' in referencing
> the functions.  But I do not know how to change the configuration.

./configure --disable-asm ?

re-run configure, make clean, then make

./configure && make works out-of-the box with MSys/MinGW without Cygwin's
cygwin1.dll dependency.

The attached patch to configure will enable LDAP support with the
keyserver helpers. If you're going to use MinGW stick with the 3.2 version
of the runtime.

- --
John P. Clizbe                   Inet:   JPClizbe(a)comcast DOT nyet
Golden Bear Networks             PGP/GPG KeyID: 0x608D2A10
  "Most men take the straight and narrow. A few take the road less
traveled.  I chose to cut through the woods."
Version: GnuPG v1.3.6 (Windows 2000 SP4)
Comment: Annoy John Asscraft -- Use Strong Encyption
Comment: Using GnuPG with Mozilla -

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: configure.diff
Url: /pipermail/attachments/20040523/e2181338/configure.txt

More information about the Gnupg-users mailing list