group options

Thomas Jones admin at
Thu Mar 3 20:24:29 CET 2005

On Thursday 03 March 2005 12:43 pm, DBSMITH at wrote:
> Yes, there is a --group command.  Stick in your gpg.conf file:
> group name_you_want_to_use = keyid1 keyid2 keyid3 keyid4
> David
> I tried this and the error I am getting is:
> gpg: no = sign found in group definition "HlthStream"
> my conf file is
> group HlthStream = keyid1 keyid2
> no-tty
> no-secmem-warning
> no-mdc-warning
> Any ideas?
> thank you,
> Derek B. Smith
> OhioHealth IT
> UNIX / TSM / EDM Teams
> 614-566-4145
GPG seems to be reading your group value(s) not as expected. 

Referencing the source file g10.c:
      log_error(_("no = sign found in group definition \"%s\"\n"),name);

The strsep function is attempting to access the token(value) in the &string 
variable. The first token is separated from the group name via the equals 

Try to concatenate the name declaration, separation character(=), and value 
list. I've never tried, but you may need to quote the arguments(group value 
list) to keep it from being expanded unexpectedly in the configuration file. 
I know that passing the group command to bash requires quotes on my system.

See if that has a desired effect.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : /pipermail/attachments/20050303/84178eaa/attachment.pgp

More information about the Gnupg-users mailing list