Card readers supported by GPG's internal drivers

Tony Whitmore tony at
Thu Jul 13 23:44:21 CEST 2006

On Wed, Jul 12, 2006 at 05:15:34AM -0500, Jonathan Rockway wrote:
>> Two possible options:
>> First, if you're using CCID, does your user have proper write permission
>> to the /dev/usb node?  (Maybe try sudo gpg --card-status?)

Yes, I've been manually changing the permissions on the device nodes to
give the scard group (of which my user account is a member) read-write
access. But this hasn't changed anything. (Running using sudo has the
same output with the addition of a line warning about ownership of

>> Secondly, have you tried pcscd?  Install that, start the daemon, then
>> run a tool like pcsc_scan (comes with debian's pcscd package, IIRC).
>> Between pcsc_scan's output and pcscd's logfile, you might have much
>> better luck debugging.  For my card reader (built-in to my Dell laptop),
>> I had to configure pcscd to "use buggy drivers" since apparently my card
>> reader was untested.  It works fine, and now I use my OpenPGP card for
>> signing mail and logging into machines via ssh.

Yes, I've tried pcscd. Sadly the licence of the driver for my smartcard
reader is unclear (the LICENCE file is missing from the download .zip
file). The card was certainly detected by pcscd but I had problems
completing very basic steps - pcscd segfaulted when I tried to set my
name on the card.

So I wanted to see if I could get the gpg internal system working as
(potentially) the easiest route!



-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 254 bytes
Desc: OpenPGP digital signature
Url : /pipermail/attachments/20060713/d0661ed2/signature.pgp

More information about the Gnupg-users mailing list