Gnupg make error

Henry Hertz Hobbit hhhobbit7 at
Wed Mar 8 10:59:51 CET 2006

CHRISTINA MARJI <marji22 at> wrote:
>I have downloaded gnupg source code from
> I get the following errors when I run the
>make utility:
>make[1]: Entering directory
>../g10/gpg --homedir . --quiet --yes
>--no-permission-warning --import ./pubdemo.
>gpg: mpi larger than indicated length (124 bytes)
>gpg: read_block: read error: invalid packet
>gpg: no valid OpenPGP data found.
>gpg: import from `./pubdemo.asc' failed: invalid
>make[1]: *** [prepared.stamp] Error 2
>make[1]: Leaving directory
>make: *** [check-recursive] Error 1
>Can someone help me regarding this matter. 
>Thank you
>Christina Michael

Since I had not built (still using 1.4.2), and nobody
else has responded in the digest (if somebody else responded,
I apologize) I downloaded and had no problems.  You
can help by starting over (by that I mean start with a fresh
set of files from the very beginning, including a new download
if you feel that is necessary) and doing it the following way
in some sort of SH type shell, bash, sh, ksh:

[hhhobbit at gandalf ~]$ bzip2 -dc gnupg- | tar -xf -
[hhhobbit at gandalf ~]$ cd gnupg-

[hhhobbit at gandalf gnupg-]$ ./configure > LOG.config 2> ERR.config
[hhhobbit at gandalf gnupg-]$ ls -l LOG.* ERR.*
-rw-r--r--  1 hhhobbit hhhobbit     0 Mar  8 02:38 ERR.config
-rw-r--r--  1 hhhobbit hhhobbit 13899 Mar  8 02:39 LOG.config

[hhhobbit at sirius gnupg-]$ ls -l LOG.* ERR.*
-rw-r--r--  1 hhhobbit hhhobbit     0 Mar  8 02:38 ERR.config
-rw-r--r--  1 hhhobbit hhhobbit   108 Mar  8 02:40 ERR.make
-rw-r--r--  1 hhhobbit hhhobbit 13899 Mar  8 02:39 LOG.config
-rw-r--r--  1 hhhobbit hhhobbit 44623 Mar  8 02:41 LOG.make

[hhhobbit at sirius gnupg-]$ cat ERR.make
ttyio.c: In function `tty_get_ttyname':
ttyio.c:103: warning: null argument where non-null required (arg 1)

You can see that I took the defaults and it worked just fine. I
think one of your files somehow got altered.  I don't know which
one it is, or how or even when it got corrupted.  BTW, I suggest
ALWAYS doing your builds not just of GnuPG, but all software this
way to let you know if before you even made it to make whether you
were able to get a good configure.  You also didn't specify if you
gave configure any options.  I will assume you didn't.

You SHOULD end up with a ZERO size ERR.config file.  If you don't,
start there.

Henry Hertz Hobbit

Switch to Netscape Internet Service.
As low as $9.95 a month -- Sign up today at

Netscape. Just the Net You Need.

New! Netscape Toolbar for Internet Explorer
Search from anywhere on the Web and block those annoying pop-ups.
Download now at

More information about the Gnupg-users mailing list