Fedora Core 5 and SCR335

Andreas Martin ama at inmedias.it
Fri May 19 10:51:43 CEST 2006

Hi Werner.

Thanks for your answer.

Werner Koch schrieb:
> Andreas Martin <ama at inmedias.it> writes:
>> # ls -l /proc/bus/usb/001
>> -rw-rw---- 1 root scard 111 18. Mai 13:32 005
> Check with fuser or lsof that no other process is using this file.

fuser an lsof don't tell anything about other processes using this file.

> Try something like 
>  echo XXXXXXXXX >/proc/bus/usb/0001 && hd /proc/bus/usb/0001
> to see whether you can write and read at all to the device.

Writing with echo to the device returns an error (for both, "andi" and
# echo XXXXXXXX >/proc/bus/usb/002/003
bash: echo: write error: Das Argument ist ungültig

But redirecting less works fine (for both users):
# less gnupg-ccid >/proc/bus/usb/002/003

> Are you using 1.4.3?

I tried v1.4.3 that comes with Fedora Core 5 and I downloaded v1.4.3 and
v1.4.2 from gnupg.org compiled an installed it (libusb and libusb-devel
are installed). I even tried --enable-selinux-support with configure,
enabled and disabled SElinux, but nothing happened :-(

The other way round: Does anybody know, that the combination of Fedora
Core 5, SCM SCR335 USB and GnuPG is working? Changing the distribution
would be an alternative...

Kind regards


More information about the Gnupg-users mailing list