external pinpad, gnupg, SPR532 PinPad SmartCard Reader

Michael Parker MichaelParker at gmx.de
Sun Feb 11 15:44:37 CET 2007

 I tried to setup an external smartcard reader with a pinpad and on gentoo I 
don't get it to work. 
 On an ubuntu-installation the pin isn't enterd by the external pinpad but by 
the regualar keyboard and that works fine. 
 On gentoo I'm asked to enter the pin on the pinpad of the reader. After 
entering it doesn't find the secret key. 
 Some details of my system: 
 It's a 
  Bus 002 Device 002: ID 04e6:e003 SCM Microsystems, Inc. SPR532 PinPad 
SmartCard Reader 
  pinentry-program /usr/bin/pinentry-qt 
 default-cache-ttl 1800
  grep -v ^# gpg.conf | grep -v ^$ 
 keyserver hkp://subkeys.pgp.net 
 hidden-encrypt-to 0219F045 
 hidden-encrypt-to 18BA2C46 
 default-recipient 0219F045 
 default-recipient 18BA2C46 
 reader access works 
 gpg --card-status 

   Application ID ...: D276000124010101000100000AA60000 
 Version ..........: 1.1 
 Manufacturer .....: PPC Card Systems 
 I tried those variations of useflags settings 
  emerge -tpv gnupg 
 Calculating dependencies... done! 
 [ebuild   R   ] app-crypt/gnupg-2.0.2  USE="X nls 
smartcard -bzip2 -doc -ldap -openct -pcsc-lite (-selinux)" 0 kB 
 emerge -tpv gnupg 
 These are the packages that would be merged, in reverse order: 
 Calculating dependencies... done! 
 [ebuild   R   ] app-crypt/gnupg-2.0.2  USE="X nls pcsc-lite 
smartcard -bzip2 -doc -ldap -openct (-selinux)" 0 kB 
 gpg-agent is running 
  ps ax | grep agent 
 23837 ?        Ss     0:00 gpg-agent --daemon 
 installed software 
       Latest version available: 2.0.2 
       Latest version installed: 2.0.2 
       Size of files: 3,876 kB 
       Homepage:      http://www.gnupg.org/ 
       Description:   The GNU Privacy Guard, a GPL pgp replacement 
       License:       GPL-2 
       Latest version available: 0.7.2-r2 
       Latest version installed: 0.7.2-r2 
       Size of files: 389 kB 
       Homepage:      http://www.gnupg.org/aegypten/ 
       Description:   Collection of simple PIN or passphrase entry dialogs 
which utilize the Assuan protocol 
       License:       GPL-2 
       Latest version available: 1.3.1-r1 
       Latest version installed: 1.3.1-r1 
       Size of files: 822 kB 
       Homepage:      http://www.linuxnet.com/middle.html 
       Description:   PC/SC Architecture smartcard middleware library 
       License:       as-is 
       Latest version available: 2.1.8 
       Latest version installed: 2.1.8 
       Size of files: 974 kB 
       Homepage:      http://www.libchipcard.de 
       Description:   Libchipcard is a library for easy access to chip cards 
via chip card readers (terminals). 
       License:       GPL-2 
 *  dev-libs/opensc 
       Latest version available: 0.10.1 
       Latest version installed: 0.10.1 
       Size of files: 1,275 kB 
       Homepage:      http://www.opensc.org/ 
       Description:   SmartCard library and applications 
       License:       LGPL-2 
 *  dev-libs/openct 
       Latest version available: 0.6.6 
       Latest version installed: 0.6.6 
       Size of files: 550 kB 
       Homepage:      http://opensc.org/ 
       Description:   library for accessing smart card terminals 
       License:       BSD 
 Does the external pinpad in between work at all under linux ? 
 If ubuntu is configured that way, so pins are still enterd by the regular 
keybord, how do I configure it the same with gentoo ?
Do I have to change my software/configuration ? 
 Any hints will be appreciated 

More information about the Gnupg-users mailing list