pinentry-mac never displays any UI

Richard Bronosky BrunosJunk at
Fri Oct 5 01:48:48 CEST 2007

On 10/4/07, Benjamin Donnachie <benjamin at> wrote:
> Richard Bronosky wrote:
> > I got a lead on how to use pinentry, and now have an error message to report:
> > echo GETPIN|/Applications/
> > OK Your orders please
> > 2007-10-01 14:21:54.669 pinentry-mac[6312] *** _NSAutoreleaseNoPool():
> > Object 0x31eaf0 of class NSCFString autoreleased with no pool in place
> > - just leaking
> The NSAutoreleaseNoPool() message is a known harmless bug and I have a
> patch to fix it.
> > Again, the icon appears in the dock and bounces once, but no UI.  I
> > hope that helps.
> What application are you using it with?  Version of MacOS?  Chipset?

Application?  First I tried doing the complete approach that your
howto describes.  Then I tried adding it as the pinentry-program in
~/.gnupg/gpg-agent.conf, and tested it via command line.  Still no
luck, so I tried sending the GETPIN command to it manually with the
results that you responded to.

Version of MacOS?  Mac OS 10.4.10

What do you mean by Chipset? (did you miss my first email?)  From my
first email:
MacBookPro, Intel Core 2 Duo 2.2GHz, 2GB DDR2
uname -a
Darwin IT-F1-P-RBRONOSKY 8.10.1 Darwin Kernel Version 8.10.1: Wed May
23 16:33:00 PDT 2007; root:xnu-792.22.5~1/RELEASE_I386 i386 i386

> When I get time I will be releasing a updated version of the mac
> pinentry program.  I suggest that you wait for that.
> Take care,
> Ben

.!# RichardBronosky #!.

More information about the Gnupg-users mailing list