Question regarding libgcrypt and openSuse 10.3

Werner Dittmann Werner.Dittmann at
Sun Oct 21 14:47:16 CEST 2007


after updating to openSuse 10.3 I tried to rebuild a project
that uses libgcrypt as a shared library. Using 10.2 I had no
problems so far. When linking my own shared library I get the
following error message from libtool:

/bin/sh ../libtool --tag=CXX   --mode=link g++  -g -O2 -D_GNU_SOURCE -I/usr/local/include   -version-info 1:0:0 -release 0.9  -o -rpath
/usr/local/lib ZIDFile.lo ZIDRecord.lo ZRtp.lo ZrtpCrc32.lo ZrtpPacketCommit.lo ZrtpPacketConf2Ack.lo ZrtpPacketConfirm.lo ZrtpPacketDHPart.lo
ZrtpPacketGoClear.lo ZrtpPacketClearAck.lo ZrtpPacketHelloAck.lo ZrtpPacketHello.lo ZrtpPacketError.lo ZrtpPacketErrorAck.lo ZrtpStateClass.lo ZrtpTextData.lo
Base32.lo ZrtpQueue.lo    -L/usr/local/lib -pthread -lccgnu2 -ldl -lrt   -L/usr/local/lib -pthread -lccrtp1 -lccgnu2 -ldl -lrt   -L/lib64 -lgcrypt -L/lib64
-lgpg-error -lpthread
grep: /usr/lib64/ No such file or directory
/usr/bin/sed: can't read /usr/lib64/ No such file or directory
libtool: link: `/usr/lib64/' is not a valid libtool archive

seems that file is missing. During ./configure the
libgrypt was found. I've tried several versions during ./configure
but none helped to solve the problem.

Is this a problem of libgcrypt or a problem of the openSuse 10.3
package. Of course I installed the devel packages :-)

Werner D.

More information about the Gnupg-users mailing list