Decryption error

Max Allan max.allan at
Thu Jan 10 09:35:27 CET 2008

You can try to run ldd on the binary (use the full path to gpg, ldd won't search $PATH for you). That will show all libraries the
binary wants and if they aren't found. 
This might save you some repeated copying libs one by one onto the box!
It will also show that if you know libgcc is somewhere on the box but fails to be found, then you need to set your library search
path again (this env var varies depending what OS you're on. Solaris uses LD_LIBRARY_PATH).
I'm being a bit vague about the answer because the exact command you need will depend on the OS and the shell. You said you'd
already set some environment variables so I assume you know how to do it. 
In case you don't, here is a clue : if you're running sh then the assignment command needs to be followed by an 'export' for future
shell scripts to find it. If you're running bash/csh/ksh you can do it all in one.
Check it's properly set by doing an echo in a new shell (example in sh) :
$ VAR=val
$ echo $VAR
$ sh
$ echo $VAR
$ exit
$ export VAR
$ sh
$ echo $VAR

Every time you logout, you'll need to reset it. To make it permanent, it'll need to go in one of your dot files (.profile, .login,
.cshrc etc)
More unix training is available at my normal hourly rate ;-)
 gpg: fatal: open failed: No such file or directory


I have set environment variables both when I compiled gpg and when I run the restore utility but I can't seem to get past this

I have worked with the Amanda folks but still haven't figured this one out.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20080110/9f6b999d/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 487 bytes
Desc: not available
URL: </pipermail/attachments/20080110/9f6b999d/attachment.pgp>

More information about the Gnupg-users mailing list