Not able to decrypt gpg file

David Shaw dshaw at
Tue Sep 23 18:13:46 CEST 2008

On Fri, Sep 19, 2008 at 03:08:17PM +0530, Bindu Ramakrishnan wrote:
> Hi,
> I have created a gpg key in my pc and the key was used for encrypting a  
> file. Now for official reasons I had to shift to another pc and I tried  
> to import my secret key also to the new pc. But I didn't find any way of  
> doing it and so finally I copied the .gnupg folder from my old pc to the  
> new pc. Now whenever I try gpg command I get following error
> gpg: /home/bindur/.gnupg/gpg.conf:1: keyword too long
> gpg: /home/bindur/.gnupg/gpg.conf:2: invalid option


> gpg: /home/bindur/.gnupg/gpg.conf:163: invalid option
> Unfortunately now I am getting the same error in my old pc also. Now I  
> am stranded without any options for decrypting the file.
> Can anyone please help me to come out of this mess?

It seems you managed to replace your gpg.conf config file with
something completely not a gpg.conf file.  Take a look at the file and
see what happened to it.  If need be, you can delete it and run with
the defaults, or try to find a backup copy of it.


More information about the Gnupg-users mailing list