.gnupg/gpg.conf permissions

Robert Holtzman holtzm at cox.net
Tue Apr 7 03:10:35 CEST 2009

On Mon, 6 Apr 2009, David Shaw wrote:

> On Apr 6, 2009, at 6:25 PM, Robert Holtzman wrote:
>> Just tried to d/l a key and was greeted with
>> [holtzm at localhost]~$ sudo gpg --recv --keyserver pgp.mit.edu 
>> A373FB480EC4FE05
>> [sudo] password for holtzm:
>> gpg: WARNING: unsafe ownership on configuration file 
>> `/home/holtzm/.gnupg/gpg.conf'
>> gpg: external program calls are disabled due to unsafe options file 
>> permissions
>> gpg: keyserver communications error: general error
>> gpg: keyserver receive failed: general error
>> I have downloaded keys from this server before with no problems. The 
>> ownership on the file in question is
>> -rw------- 1 holtzm holtzm 9419 2008-10-04 21:58 ./.gnupg/gpg.conf
> Why are you downloading keys as root (i.e. using sudo)?

It's a bad habit I got into when I started using ubuntu. Running the 
command from my user account worked. I may have to stick with debian.

Thanks for pointing out my problem.

Bob Holtzman
To enjoy life take big bites. Moderation is for monks.
                                           Lazarus Long

More information about the Gnupg-users mailing list