Help! Please with decryption failed: No secret key (gpg in batch mode)

Joseph Oreste Bruni jbruni at
Wed Apr 29 17:29:28 CEST 2009

Your automated process is not running with the same home directory as  
your login shell.


On Apr 29, 2009, at 8:24 AM, Schrago, Gerard wrote:

> Hi all,
> Sorry to insist but I really need someone that can answer my question.
> Why a running process cannot decrypt a file while the very same  
> shell script invoked within a ssh session does it?
> Please!
> With my best regards.
> Gerard.
> -----Original Message-----
> From: Schrago, Gerard
> Sent: mardi, 28. avril 2009 17:19
> To: 'gnupg-users at'
> Subject: Help with GPG in batch mode
> Hi all,
> Help needed in the following issue; I hope not to bother anyone but  
> I need an advise from an expert.
> If the verbose provided by the --debug-level guru would be of some  
> help I can send it in a further mail.
> I have to use GnuPG in batch mode to enable a running process to  
> decrypt encrypted file.
> If I run the shell script through ssh (with the specific user that  
> was previously used to set the keys and has its proper .gnupg  
> directory) this works fine despite the following warning:
> WARNING: message was not integrity protected.
> But if I have the running process invoking the very same script, the  
> response is:
> gpg: encrypted with RSA key, ID 911633C3
> gpg: decryption failed: No secret key
> I have then tried to modify the script to define home directory  
> using --homedir and I got the following:
> gpg: WARNING: unsafe permissions on homedir `/home/superagt/'"
> gpg: keyring `/home/superagt//secring.gpg' created
> gpg: keyring `/home/superagt//pubring.gpg' created
> gpg: encrypted with RSA key, ID 911633C3
> gpg: decryption failed: No secret key
> It is to note that I see neither in /home/superagt/ nor in /home/ 
> superagt/.gnupg/ the secring.gpg pubring.gpg announced.
> Thanks per advance for your help and support.
> With my best regards.
> Gérard Schrago
> _______________________________________________
> Gnupg-users mailing list
> Gnupg-users at

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2557 bytes
Desc: not available
URL: </pipermail/attachments/20090429/05390cbe/attachment-0001.bin>

More information about the Gnupg-users mailing list