GPG: Missing self signature Error

Rahul R rahul.raviz at
Mon Nov 23 13:20:01 CET 2009

Hi All,

I have GNUPG versions 1.2 and 1.4 installed on two servers A and B

I got a gpg key from a client, i imported it on Server B with out any error
messages and I am able to encrypt and decrypt data.

but on server A iam getting many errors.

/usr/local/bin/gpg --homedir /root/.gnupg --import client_name.pkr
gpg: key DFEB876D: no valid user IDs
gpg: this may be caused by a missing self-signature
gpg: Total number processed: 1
gpg:           w/o user IDs: 1

then i tried

usr/local/bin/gpg --homedir /root/.gnupg --allow-non-selfsigned-uid --import

this time it worked..

but when i try to encrypt the data it is giving me an error

usr/local/bin/gpg --homedir /root/.gnupg --output a.txt.gpg "gpg_key"
--encrypt a.txt

gpg: missing self-signature

i don know why it is behaving like this.. bcoz on B i have no such issues.

is this bcoz of the version differences? is there anyother command to solve
this error. or do i need to upgrade the gpg version on A? please advice.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20091123/48a76f2d/attachment-0001.htm>

More information about the Gnupg-users mailing list