can't connect to `C:/Program Files/GNU/GnuPG//S.gpg-agent'

listac at listac at
Thu Oct 29 13:59:21 CET 2009

I pretty much have a similar problem. WIth gpg4win as well as with linux.
However, using gpg4win I do not see any usage problem asides this message.

When using linux, even when I start gpg-agent --daemon, it creates it's
socket under /tmp/<cryptdir>, while gpg searches for .gnupg/S.gpg-agent.
The environment the daemon exports seems to be ignored.

So I have to manually link .gnupg/S.gpg-agent to theat file below /tmp to
be able to work with a smartcard at all.

# gpg-agent --daemon
GPG_AGENT_INFO=/tmp/gpg-mS2h6N/S.gpg-agent:1510:1; export GPG_AGENT_INFO;

# gpg2 --card-status
can't connect to `/root/.gnupg/S.gpg-agent': No such file or directory

-> Same error message as if no gpg-agent has been started manually at all

# ln -s /tmp/gpg-mS2h6N/S.gpg-agent /root/.gnupg/S.gpg-agent
# gpg2 --card-status
gpg: selecting openpgp failed: Card not present

> Hi,
> Has anyone got any idea how to resolve the following error:
> can't connect to `C:/Program Files/GNU/GnuPG//S.gpg-agent'
> I get this error when issuing the following command
> gpg --passphrase-fd 0 --batch --output out.dat --decrypt in.pgp
> This worked fine until a few days ago but now it won't work at all.
> There's nothing wrong with the file because it decrypts fine without the
> passphrase-fd argument.
> Setup is Windows XP Pro and PGP is...
> C:\Program Files\GNU\GnuPG\Work>gpg --version
> gpg (GnuPG) 2.0.12 (Gpg4win 2.0.0)
> libgcrypt 1.4.4
> Copyright (C) 2009 Free Software Foundation, Inc.
> License GPLv3+: GNU GPL version 3 or later
> <>
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law.
> Home: C:/Program Files/GNU/GnuPG/
> Supported algorithms:
> Pubkey: RSA, ELG, DSA
>         CAMELLIA192, CAMELLIA256
> Hash: MD5, SHA1, RIPEMD160, SHA256, SHA384, SHA512, SHA224
> Compression: Uncompressed, ZIP, ZLIB, BZIP2
> Regards
> Dave
> Registered Office: Turpin Distribution Services Ltd, Pegasus Drive,
> Stratton Business Park, Biggleswade, Bedfordshire, SG18 8TQ, UK. *****
> Registered in England No. 1331778 ***** This email may contain
> confidential information and/or copyright material. This email is intended
> for the use of the addressee only. Any unauthorised use may be unlawful.
> If you receive this email by mistake, please advise the sender immediately
> by using the reply facility in your email software.
> _______________________________________________
> Gnupg-users mailing list
> Gnupg-users at

More information about the Gnupg-users mailing list