problem with ownertrust value

Paul Richard Ramer free10pro at
Sat Feb 27 08:11:35 CET 2010

On Fri, 2009-12-04 at 02:11 -0200, Juan Manuel Fernandez Arauz wrote:
> Hello, i have the this doubt:
> I have tried this:
> gpg --local-user UID1 --edit-key UID3
> > trust
> 5
> and later:
> gpg --local-user UID2 --edit-key UID3
> > trust
> 1
> But if i later execute this again:
> gpg --local-user UID1 --edit-key UID3
> i see "trust: dont know", and it supose that that value was for UID2,
> not for UID1.
> So i think im setting the ownertrust value for all users.

Not quite.  You are not setting the ownertrust value for all users but
for yourself, as a person.  The ownertrust value is about how much you,
as a person, trust the possessor of the key to validate keys that he
signs.  Even though you tried setting the ownertrust by specifying a
different "local user" each time, GnuPG didn't change the value in
relation to the "local user" but in relation to you the person.

> How can i set the ownertrust value user by user for a given UID?
You can't.  See the above.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 665 bytes
Desc: This is a digitally signed message part
URL: </pipermail/attachments/20100226/96a2120e/attachment.pgp>

More information about the Gnupg-users mailing list