Problem with migration from 1.2.4 to 2.0.9

Michel Mansens spelbord at
Tue Apr 12 14:30:42 CEST 2011


Im running Linux Redhat. The current version come with the installation of
the OS.

> cat ~/.gpg-agent-info

But is seems we have now problems with the agent process. We could decrypt
data when I imported the key but now not at all. And when I tried to run the
socket (agent) process we crashed the complete server and we had to
hard shut-down it.

Is it not possible to not use the agent?

We also now trying to create a key on our production server and also this
giving problems.  It hangs when you have to type random letters after the
password prompt.


2011/4/12 Charly Avital <shavital at>

> Michel Mansens wrote the following on 4/12/11 3:31 AM:
> > can't connect to `/home/user/.gnupg/S.gpg-agent': No such file or
> directory
> > gpg-agent[22946]: command get_passphrase failed: Operation cancelled
> > gpg: cancelled by user
> > Can't edit this key: General error
> >
> > How can I fix this?
> I tried to find out from the raw source of your e-mail what platform you
> are running. But as it often happens with addresses, this
> kind of information is not displayed.
> The current stable gpg2 is 2.0.17.
> How did you install 2.0.9?
> 2.0.9 uses gpg-agent to cache the passphrase, and pinentry to enter the
> passphrase.
> "can't connect to `/home/user/.gnupg/S.gpg-agent': No such file or
> directory" is typical of gpg-agent not being activated.
> I'm a Macintosh user, and I don't know enough about your problem to help
> you really.
> If you would post to the list more information about what OS you are
> running (and its version), how you installed 2.0.9, and the output to
> the following commands after the prompt in Terminal:
> gpg-agent
> cat ~/.gpg-agent-info
> I hope that more knowledgeable list members will be able to help.
> Charly
> MacOS 10.6.7-MacBook Intel C2Duo 2GHz-GnuPG 1.4.11-MacGPG 2.0.17
> Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.6; en-US; rv:
> Gecko/20110303 Thunderbird/3.1.9 Enigmail 1.2a1pre (20110408-1936)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20110412/3baec56b/attachment-0001.htm>

More information about the Gnupg-users mailing list