Having trouble getting GPG to accept input from a pinpad

Paul Richard Ramer free10pro at gmail.com
Tue Jan 11 12:09:54 CET 2011

On 01/03/2011 02:25 AM, Michel Messerschmidt wrote:
> Have you tried it with gnupg 2.0.x ?
> IIRC you need at least 2.0.12 for the SPR-532 pinpad and gnupg-agent
> should be running. 
> If not, please post more details about your environment and how you
> execute gnupg. The pinpad works for me, so I guess you will find a way.

Good news--it works.  Initially, I tried gpg2 (version 2.0.14), but it
didn't work.  Instead, I got an error message that scdaemon wasn't
running.  I searched for scdaemon on my system with "which scdaemon",
but I couldn't find it.

But now I can find scdaemon with "which scdaemon", and the only thing
that has changed has been that I compiled some software, installed some
packages, and, just this last evening, performed an update on my system.
 I hadn't had any success with the pinpad until some time after the
update last night.

So I don't know what happened to fix my situation (I wish I knew).  But
thank you to all of you who helped me.  You have been a big help. :-)


PGP Key ID: 0x3DB6D884
PGP Fingerprint: EBA7 88B3 6D98 2D4A E045  A9F7 C7C6 6ADF 3DB6 D884

More information about the Gnupg-users mailing list