Question regarding the migration of the pgp keyring to gpg

Pramod.R Pramod.R at
Fri May 27 14:24:04 CEST 2011

Hi David,

Thanks so much for your response on this.

Now, when I tried decrypting a pgp encrypted file through a gpg (using the gpg --decrypt command), I'm running into this problem of "idea encryption (0) failed" even when I tried compiling one of the idea.c that I downloaded, using the command: gcc -Wall -O2 -shared -fPIC -DBIG_ENDIAN_HOST -o idea idea.c

I came across one of your posts in the below link where you mentioned that you edited the idea.c for the "endianness" and got it working:

Could you please let send me the latest version of the idea.c that has taken care of this problem?

Thanks so much in advance as this would mean so much for me..

Let me know if you need any clarity on my question...

Warm Regards,
Pramod R 

-----Original Message-----
From: David Shaw [mailto:dshaw at] 
Sent: Friday, April 15, 2011 7:02 PM
To: Pramod.R
Cc: gnupg-users at
Subject: Re: Question regarding the migration of the pgp keyring to gpg

On Apr 15, 2011, at 1:23 AM, Pramod.R wrote:

> Hi,
> We are migrating from pgp 6.5.8 to gpg 1.4.11. I  had a question regarding the migration of the public keys and the private keys:
> Is there a way where I could migrate the entire key ring at one go? I'm currently extracting my keys from pgp using the pgp -dx <key-id> command and then importing each of these into the gpg. Is there one single command which would help me migrate the entire key ring at once?

Yes.  PGP 6.5.8 keyring files are directly importable into GnuPG.  Just find your pubring.pkr and secring.skr files and do:

  gpg --import /path/to/pubring.pkr
  gpg --import /path/to/secring.skr

That will import all of the keys at once.


More information about the Gnupg-users mailing list