GnuPG decryption problem

Peter Lebbing peter at
Tue Nov 1 15:47:08 CET 2011

> m.aflakparast at wrote:
>> Thank you Dave,
>> I tried again with this command:
>> gpg --decrypt-file "myfile.gpg"
>> and entered the passphrase when I was asekd to enter it.
>> But, this error comes up:
>> gpg: encrypted with 1 passphrase
>> gpg: decryption error: bad key!
> Is that it, or is there any more diagnostic information?

That is the exact same error message you would get when you simply enter an
incorrect passphrase. The file might be damaged, or you might have misunderstood
the sender (that is, you actually enter the wrong passphrase).

If the passphrase contains "special" symbols (umlauts, c-cedillas, anything
other than letters, numbers, spaces and a few symbols), you might have a problem
with entering those, though. That is something that doesn't always work
correctly out-of-the-box. And which is beyond my expertise, by the way.

The website you mentioned earlier on installing the gnupg command line tool
without using GPG4Win calls their method "the proper way to install the GnuPG in
a modern Windows environment". I respectfully disagree, usually the proper way
/is/ using GPG4Win. There are situations where the more "manual" method
described on that site is appropriate, but not for day-to-day use. I think
you'll be better off with GPG4Win.

Good luck,


PS: The following table could be useful. It's a list of symbols that I think
shouldn't give problems when entering those. If one of the symbols in your
passphrase is not in this table, you might have a "language issue" that prevents
you from entering that symbol in the passphrase.

  0 @ P ` p
! 1 A Q a q
" 2 B R b r
# 3 C S c s
$ 4 D T d t
% 5 E U e u
& 6 F V f v
´ 7 G W g w
( 8 H X h x
) 9 I Y i y
* : J Z j z
+ ; K [ k {
, < L \ l |
- = M ] m }
. > N ^ n ~
/ ? O _ o

I use the GNU Privacy Guard (GnuPG) in combination with Enigmail.
You can send me encrypted mail if you want some privacy.
My key is available at

More information about the Gnupg-users mailing list