Public Keys not showing up in "Choose Recipients"

BassToGo123 Ivanbrodsky at
Fri Mar 1 07:14:02 CET 2013

I have used OpenPGP a few times before and it worked just fine, I just began
to use it again and have run into an issue.

I wish to encrypt text written on IOS "Notepad". So I copy and paste
someone's public key into a notepad file, and then Import into my "GPG
Keychain Access". It then loads the public key along with an email and all
that information.

I type some text in Notepad, I then
highlight->right-click->Services->OpenPGP:Encrypt Selection

This opens a box "Choose Recipients", and only a couple of the public keys I
have on my PGP Keychain Access, namely ones I had loaded on months ago
(which showed up immediately back then)

I have tried nearly a half dozen public keys and they all fail to show up in
this "Choose Recipients" box, preventing me from encrypting my text.
Essentially, my problem is that new public keys will not show up outside of
my keychain.

I have tried:
-Multiple different public keys
-Reinstalling GPG Keychain Access
-Updating GPG Keychain Access

Something I noticed. In the GPG Keychain Access directory of my public keys,
there is a drop down arrow next to the public keys I have saved, this seems
to reveal more about the keys. The ones that DO show up in the "Choose
Recipients" box, under the "Type" column have both types "uid" and "sub".
While the public keys that DO NOT show up, are missing the "sub".

I am new to this and it is almost a foreign language of encryption jargon,
please help me out!!

Thank you!

View this message in context:
Sent from the GnuPG - User mailing list archive at

More information about the Gnupg-users mailing list