command-line gpg not working

stephen steptan at
Sun Mar 17 22:59:51 CET 2013

First, let me say that

Both exist and both seem to work.

When I run from the command line
gpg2 --gen-key

Everything goes fine until the passphrase step, where the program skips
ahead and errors:

Change (N)ame, (C)omment, (E)mail or (O)kay/(Q)uit? O
You need a Passphrase to protect your secret key.

gpg: problem with the agent: No pinentry
gpg: Key generation canceled.

This process launches gpg-agent --daemon on its own. So I tried killing
gpg-agent --daemon --use-standard-socket

launching my own:
gpg-agent --daemon --pinentry-program=/bin/pinentry

But the behavior is the same.

OS: linux, Fedora 18

# gpg2 --version
gpg (GnuPG) 2.0.19
libgcrypt 1.5.0

# gpg-agent --version
gpg-agent (GnuPG) 2.0.19
libgcrypt 1.5.0


-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20130317/4f635ab8/attachment.html>

More information about the Gnupg-users mailing list