Beta for 2.1.1 available

Hugo Hinterberger Hugo.Hinterberger at
Wed Dec 10 09:57:30 CET 2014


I am still trying to find a working solution to verify incoming files and 
messages with GnuPG on Windows … and I want the solution to be able to 
handle PGP/MIME messages read through Gmane using elliptic curve based keys. 
I just have started to try signing messages.

> A misunderstanding of EOL conventions?

I tried signing a text several times, every time with the same result, the 
broken signature.

I just tried to reproduce my previous results; now it seems to work.
What is different? I ran Windows Update. I tried it on the console before 
using GPA.

OK, so I did some more experimenting:
1. Sign “Clipboard” in GPA using key 1.
2. Sign signed text in “Clipboard” in GPA using key 2.
3. Verify text in “Clipboard” in GPA.
4. Verify text in “Clipboard” in GPA.

After 1.: Signed text looks fine, just like on the console.
After 2.: Signed text looks fine, just like on the console (two “BEGIN PGP 
SIGNED MESSAGE” and two PGP signature blocks).
After 3.: Validation successful (valid), message stripped of signature is 
mangled (empty lines inserted).
After 4.: Validation successful (valid), message stripped of signature is 
mangled again (now each line is followed by two empty lines).

Copying text from “Clipboard” in GPA to Windows clipboard results in message 
stripped of signature after step 4 to not be mangled, except for two 
newlines at the end of the message (they were not there at the start).
The text copied to the Windows clipboard is mangled again (just the 
signature part): every line created by GPA is followed by 2 empty lines, the 
original message seems unchanged.
Verifying the content of the Windows clipboard by pasing it into the 
“Clipboard” in GPA results in a “"Clipboard" contained no OpenPGP data.” 

Something is rotten in the state of GPA.


More information about the Gnupg-users mailing list